Did you turn off the option by "Enable Gamepad" in the menu "Enable Hat Switches" because if it is checked on, it will mess up the buttons.