Results 1 to 8 of 8
  1. #1
    Player Dsherman's Avatar
    Join Date
    Mar 2011
    Posts
    72
    Character
    Dsherman
    World
    Siren
    Main Class
    WHM Lv 99

    Opening Movie does not play correctly

    There is a configuration setting in FFXIConfig to play the Opening Movie. I have usually had this setting turned off. For most people, always playing that Opening Movie is a big waste of time, but it is still something that should be able to be played for people playing for the first time.

    However, when that setting is turned on, and the Opening Movie is allowed to be played, there is a problem. The FFXI client does not re-establish the connection made by the Playonline Viewer until the box to accept the "Rules of Conduct" has been accepted. And that box does not appear until AFTER the entire movie has been played. In the time that it takes for the movie to run, the connection times out. Which means that you must go back to the Playonline Viewer and login again! And of course, when the PLAY button is done after that login, the movie starts over again from the beginning! If the user does not press keys to skip the play of the movie, they will once again time out and the whole thing starts over yet again.


    Also, the aspect ratio of the movie while it is playing is incorrect. It does seem to have a 16:9 aspect ratio, but its appearance on screen is like it is playing a 4:3 aspect ratio. If the screen is actually a 16:9 aspect ratio, the images are stretched. Of course, the original version of this movie was played in a 4:3 environment (on the PS2), so it may just have never been adjusted for more recently available aspect ratios.


    I had originally included a complaint about the movie being interrupted when the time-out occurred. But I have discovered that it is not the connection time-out that is doing it, but rather the time-out of my game pad. See the reply below for more detail.
    (0)
    Last edited by Dsherman; 05-13-2019 at 12:32 PM.

  2. #2
    Player Dragoy's Avatar
    Join Date
    Jul 2011
    Location
    Bastok
    Posts
    1,486
    Character
    Dragoy
    World
    Fenrir
    Main Class
    BRD Lv 66

    €°(((><

    You'll want to use the template from Welcome to Forum: In-Game Bugs! for this to be accepted as a bug report. :]

    As for the issue, I just tested (on Linux via Wine), and I am still able to watch the movie in its entirety, albeit a bit stretched out as you also mentioned.

    And yeah, the connection still times out, which I always found funny (sort of), but indeed, it doesn't interrupt the movie for me. I'd guess there is something external interrupting it for you, or there's something new specific to Windows that's doing it.
    (0)
    Kind Regards,
    ~ The Noob Unlimited ~



    Sore wa sore, kore wa kore.

  3. #3
    Player Dsherman's Avatar
    Join Date
    Mar 2011
    Posts
    72
    Character
    Dsherman
    World
    Siren
    Main Class
    WHM Lv 99
    In making your post, you do confirm the complaints that the time-out does occur, and the image is stretched.

    But you say you do not see the interrupt.

    For me, the interrupt occurs about the time Emelin is telling Aldo to RUN after Emelin has helped Aldo climb thru the hole in the stone wall. I know there is more to the movie than that from having seen it some time ago.

    When the interrupt occurs, it jumps to the box to accept the "Rules of Conduct" and I quickly click accept, but the time-out has occurred, and it shows an error message to indicate that. Clicking ok on that takes me back to the Playonline Viewer which shows it's own messages about the connection not being there any more.

    It is most of the way through the movie at that time. There is not a lot left. But I do know there is some more than what I see.

    It may very well be something about Windows 10 and the Full Screen mode that I run. I do run FFXI under the most recent version of Windows 10, and I do run FFXI in it's own Full Screen mode at a resolution of 1920x1080.

    I will try to add another reply with the information required by the template.
    (0)
    Last edited by Dsherman; 05-13-2019 at 04:27 AM.

  4. #4
    Player Dsherman's Avatar
    Join Date
    Mar 2011
    Posts
    72
    Character
    Dsherman
    World
    Siren
    Main Class
    WHM Lv 99
    Platform: Windows 10 PC
    ISP:Both Comcast and Consolidated Communications (CCI)
    Type of Internet Connection: Comcast is CATV. CCI is DSL
    Internet Connection Speed:Comcast is 100mb up/500mb down. CCI is 768kb up/10mb down
    Date & Time:May 12, 2019 at around noon PDT
    Frequency:Every time I allow the movie to run.
    Character Name:N/A
    Race:N/A
    World:N/A
    Main Job:N/A
    Support Job:N/A
    Area and Coordinates:N/A
    Party or Solo:N/A
    NPC Name:N/A
    Monster Name:N/A
    Steps:
    1.Use FFXIConfig to set on the option to "Play Opening Move"
    2.Login to the Playonline Viewer and use the "Play" button to start FFXI.
    3.Allow the movie to run without doing anything to interrupt it or stop it from playing.
    (0)

  5. #5
    Player Dragoy's Avatar
    Join Date
    Jul 2011
    Location
    Bastok
    Posts
    1,486
    Character
    Dragoy
    World
    Fenrir
    Main Class
    BRD Lv 66
    If it always happens at the same spot, it could mean it's caused by a corrupt file.

    Perhaps give a file check a go via the PlayOnline Viewer, before logging in (though I believe this can now be also triggered via the new config utility).

    I'd definitely also try the windowed mode (maybe windowed full screen). Unrelated to this issue, but I'm pretty sure that some Windows things (like the dimming of the desktop by the UAC) still crash the game in the real full screen mode.
    (0)
    Kind Regards,
    ~ The Noob Unlimited ~



    Sore wa sore, kore wa kore.

  6. #6
    Player Dsherman's Avatar
    Join Date
    Mar 2011
    Posts
    72
    Character
    Dsherman
    World
    Siren
    Main Class
    WHM Lv 99
    Um.... no.... file check was done. No change.

    It does not happen in the exact same spot... Just somewhere near where Emelin is telling Aldo to RUN. It varies by a few seconds. It appears that the time-out occurs a bit before that, but it takes a few seconds for whatever is interrupting the movie to notice. That is probably the reason for the small differences in when the interrupt occurs.

    It also occurs the same way on TWO SEPARATE PC's and TWO SEPARATE ISP's.

    I find it very highly unlikely that I would have the same corruption in the same spot on two separate setups.

    I have no clue why a setup on Wine would behave differently. The movie does go for several more seconds after Aldo runs. I do know that from seeing it back in the days when they still supported the PS2.
    (0)

  7. #7
    Player Dsherman's Avatar
    Join Date
    Mar 2011
    Posts
    72
    Character
    Dsherman
    World
    Siren
    Main Class
    WHM Lv 99
    I think I found it! It is not the connection time-out that interrupts the movie, but rather it is the time out of my Game Pad (Controller).

    Both of the machines where I have FFXI installed are set up with a Logitech F710 Game Pad. This is a wireless game pad with a receiver that is plugged in to a USB port on the PC. If I do not do anything with the game pad for a period of time, it will turn off to save the battery. Apparently, the receiver does pass through some kind of signal to the game when the game pad turns off. And the game has been set up in such a way that if it gets ANYTHING from the game pad receiver (even though it may not be a button press or a move of the joystick or d-pad), it will interrupt the movie and go on to the box to accept the "Rules of Conduct".

    I do wish the game would look at what it received, and if it's not a button push, ignore it. (and it would be ok to react to any button, not just a cancel button).

    If I either disconnect the receiver from the USB port, or take the batteries out of the game pad before the movie starts, the movie does play all the way thru (as long as i don't do anything else to interrupt it). It is better to take the batteries out, since disconnecting the USB port will result in not being able to use the game pad even if I do plug it back in. It won't work until I exit the Playonline Viewer and start it up again.

    My other complaints about the connection time-out and the aspect ratio of the movie still stand.
    (0)
    Last edited by Dsherman; 05-13-2019 at 01:28 PM.

  8. #8
    Player Dragoy's Avatar
    Join Date
    Jul 2011
    Location
    Bastok
    Posts
    1,486
    Character
    Dragoy
    World
    Fenrir
    Main Class
    BRD Lv 66
    A-ha!

    Yeah, that makes sense (well, it's kind of nonsense, but still). It is indeed peculiar that it's skipped when pressing nearly any key, such as 'Alt'...

    Glad you figured it out! I should have remembered to ask about the peripherals in use. :]

    I might suggest editing the first post, to add the template there, with an updated description of the issue.
    (0)
    Kind Regards,
    ~ The Noob Unlimited ~



    Sore wa sore, kore wa kore.

Tags for this Thread