Results 1 to 7 of 7
  1. #1
    Player Xanduu's Avatar
    Join Date
    Jul 2014
    Posts
    8
    Character
    Pedagogy
    World
    Carbuncle
    Main Class
    DRK Lv 99

    Savage blade quest issue

    im unable to get the savage blade quest for some reason [gm]nirusphoros told me to post it here
    (2)

  2. #2
    Player Isola's Avatar
    Join Date
    Jun 2018
    Posts
    423
    Character
    Cylinath
    World
    Asura
    Main Class
    MNK Lv 99
    Yeah, this post will accomplish nothing.

    Skill capped? Proper job? Right npc? Currently mid other wsnm?
    (0)

  3. #3
    Player Xanduu's Avatar
    Join Date
    Jul 2014
    Posts
    8
    Character
    Pedagogy
    World
    Carbuncle
    Main Class
    DRK Lv 99
    Everything is right gm said so they said post here because the developers need to look at it
    (0)

  4. #4
    Player Isola's Avatar
    Join Date
    Jun 2018
    Posts
    423
    Character
    Cylinath
    World
    Asura
    Main Class
    MNK Lv 99
    This is like the 5th time someone complained savage blade isnt working.

    It's working fine. Has been. You're doing something incorrectly.

    Verify you're not currently in the middle of another wsnm.
    (0)

  5. #5
    Player Xanduu's Avatar
    Join Date
    Jul 2014
    Posts
    8
    Character
    Pedagogy
    World
    Carbuncle
    Main Class
    DRK Lv 99
    I’ve checked I’m not in the middle of anything there is no possible way I could be doing this wrong
    (0)

  6. #6
    Player Isola's Avatar
    Join Date
    Jun 2018
    Posts
    423
    Character
    Cylinath
    World
    Asura
    Main Class
    MNK Lv 99
    Quote Originally Posted by Xanduu View Post
    I’ve checked I’m not in the middle of anything there is no possible way I could be doing this wrong
    riiiiiiiiiiiiight
    (0)

  7. #7
    Player Sirmarki's Avatar
    Join Date
    Dec 2013
    Posts
    855
    Character
    Sirmarki
    World
    Asura
    Main Class
    WHM Lv 99
    Quote Originally Posted by Xanduu View Post
    I’ve checked I’m not in the middle of anything there is no possible way I could be doing this wrong
    Well you did this post wrong on two counts.

    1. Wrong section.
    2. Not used the template.
    (0)