Results 1 to 6 of 6
  1. #1
    Player Darkhavans's Avatar
    Join Date
    Nov 2015
    Posts
    1
    Character
    Darkhavans
    World
    Odin
    Main Class
    MNK Lv 95

    Laptops with multiple GPUs default to integrated graphics

    I've been having a very frustrating problem that seems to have been an issue for quite some time now with no resolution.

    I have a laptop with two GPUs, an integrated Intel HD 4600 Graphics as well as an NVidia 860M. Normally, when launching a game (an .exe) it will automatically switch over the Nvidia card, but with FFXI this is not the case because of PlayOnline, which launches the game through a .dll file instead of directly from an .exe.

    Because of this difference, none of the normal solutions to force the application to use the Nvidia GPU work. There are numerous threads about this problem on other forums yet it seems no solution has been found despite this being a long-standing issue.

    http://www.ffxiah.com/forum/topic/44453/msi-dominator-help/
    http://www.ffxiah.com/forum/topic/44494/ffxi-wont-switch-high-performance-gpu-on
    http://www.bluegartr.com/threads/125158-Low-FPS-(FFXI-not-using-dedicated-card)
    http://forum.square-enix.com/ffxi/threads/45805-Gaming-Laptops-don-t-register-FFXI-as-a-game

    Including the last one on this very forum that is supposedly "resolved", despite no actual solution being offered. After speaking to NVidia Support as well as MSI Support (my laptop manufacturer), it seems clear this is a problem that needs to be addressed by SE and is exclusive to FFXI. I'm not very hopeful anyone will be able to offer up a solution, but unfortunately I just won't be able to play if I'm forced to use the integrated graphics.
    (1)

  2. #2
    Player SMD111's Avatar
    Join Date
    May 2011
    Posts
    332
    Character
    Kigensuro
    World
    Carbuncle
    Main Class
    SAM Lv 99
    sometimes you can (using the nvidia control panel)
    1. to add programs to a list to autoswitch to a specific hardware when it is running
    2. to always use 860M

    i do not have a laptop with an nvidia video card so i cant help you find it
    (0)

  3. #3
    Player bungiefanNA's Avatar
    Join Date
    Feb 2012
    Posts
    917
    Character
    Bungiefan
    World
    Asura
    Main Class
    BLM Lv 99
    Also, there may be a BIOS setting to disable the integrated graphics. You're going to have to dive into some settings menu somewhere to set the preference, and it varies depending on what version of WIndows you have and what driver version you have. It might also be buried in power profiles for the system.

    However, the integrated graphics should be more than sufficient to run this game nowadays. Yes, in the early 2000s this game needed a non-Intel GPU, but since about 2010 Intel GPUs have had all the features necessary.
    (0)
    www.reddit.com/r/ffxi/comments/2axr93/are_you_playing_on_the_asura_server_join_the/

  4. #4
    Player Nubi's Avatar
    Join Date
    Nov 2013
    Posts
    5
    Character
    Nubian
    World
    Asura
    Main Class
    RDM Lv 1
    I'm having this exact same issue, the game won't run on my 840m only on the integrated Intel graphics. I have manually set pol.exe, polboot.exe in the FFXI folder and the polboot.exe's in the EU and US folder to be handled by the Nvidia graphics in the Nvidia control panel but it doesn't work. I'm getting like 15fps, choppy as hell so the iGPU really doesn't cut it.
    (0)

  5. #5
    Player Catmato's Avatar
    Join Date
    Mar 2011
    Posts
    596
    Try adding ffximain.dll to be run with the discreet gpu.
    (0)

  6. #6
    Player Nubi's Avatar
    Join Date
    Nov 2013
    Posts
    5
    Character
    Nubian
    World
    Asura
    Main Class
    RDM Lv 1
    Quote Originally Posted by Catmato View Post
    Try adding ffximain.dll to be run with the discreet gpu.
    Unfortunately Nvidia control panel only allows to add .exe. There is no "Any files" option in the dropdown when browsing for files to add, only "Executables (exe)".
    (0)