Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 33
  1. #1
    Player Conini's Avatar
    Join Date
    Jan 2013
    Posts
    5
    Character
    Conini
    World
    Carbuncle
    Main Class
    DNC Lv 99

    Game-pad and FFXiPadConfig not working correctly

    The FFxiPadConfig in ToolsUS Folder is not functioning correctly.

    When assigning specific keys to different-than-default buttons, it will work in the PadConfig as well as Playonline- but does not carry over to FFXI. FFXI will reassign the buttons to the default settings.

    Example: Despite not using the Xbox-One triggers in any of the assigned buttons in the FFXiPadConfig, they will function as what ever default key they were before Pad editing or selecting any default preference.

    ...frustrating... to say the least! PadConfig worked fine prior to update.
    (7)

  2. #2
    Player Moombaz's Avatar
    Join Date
    Aug 2011
    Posts
    1
    Character
    Mumba
    World
    Asura
    Main Class
    DRG Lv 99
    I'm having the same problem. Good news is the triggers work now. I guess I'll have to get used to B and A being reversed until the fix this...
    (0)

  3. #3
    Player Ander's Avatar
    Join Date
    Nov 2015
    Posts
    1
    Character
    Ander
    World
    Phoenix
    Main Class
    BLU Lv 99

    Same problem

    I tried using each of the FFXiPadConfig tools in each of the 3 regional tools folders and made sure that ALL of them were set to the desired button config... no change. It still uses the default buttons in game.
    (0)

  4. #4
    Player Conini's Avatar
    Join Date
    Jan 2013
    Posts
    5
    Character
    Conini
    World
    Carbuncle
    Main Class
    DNC Lv 99
    Bump of Hope !

    Every time I try to open ToolsEU it just crashes... so that's good to know applying game-pad changes to other regions won't help.

    I really hope this is not going to be serviced in the NEXT update (December) >_>
    (0)

  5. #5
    Player Zhronne's Avatar
    Join Date
    Mar 2011
    Location
    Italy
    Posts
    1,048
    Character
    Sechs
    World
    Asura
    Main Class
    MNK Lv 99
    In addition to what the OP has posted, I produced several tests on all FFXI config utilities, the EU one, the US one and the JP one (I'm an european player using EU Playonline).
    The FFXI Gamepad config utility has 6 available presets
    1. Default
    2. Preset A
    3. Preset B
    4. Preset C
    5. Preset D (only available in the japanese config utility, I think this is for Xinput as well)
    6. Preset E (the new one, specifically made for Xinput)

    When you change to one of these presets the registry entries (there are 2 different ones) in the Windows registries get correctly updated and the game correctly reads all the settings of the preset you chose.
    The problems arrive when you try to customize those presets.
    Let's say you pick Preset E and want to swap two buttons around, or remove a button, or anything else.
    These customizations will be correctly written in the windows registry entry, but the game will ignore them and continue using the default setting of the preset you picked up last.
    The same happens with any preset, as far as I've seen, not just with the new one.

    I've tried to manually change data into the windows registries without using the FFXI config utility, but the result is the same, the game ignores the changes and uses whatever is the default setting of the last preset you chose.


    It works fine for the generic settings instead. Hat Switches, Slider, Force Feedback and all the options in that zone of the config software get correctly recognized when you're in-game.
    (3)
    And the autumn of life has finally come
    with the promise of winter thaw.

  6. #6
    Player Zhronne's Avatar
    Join Date
    Mar 2011
    Location
    Italy
    Posts
    1,048
    Character
    Sechs
    World
    Asura
    Main Class
    MNK Lv 99
    On another addition, there's a small issue on preset E.
    Even if the commands for "Confirm" and "Cancel" show on the right place when you use the "Test Gamepad" command, when you're in-game they get reversed.
    As some of you may know, japan and EU/US use a swapped layout for the keys that correspond to O and X on a Playstation pad, or A and B on an Xbox 360 gamepad.
    In Japan Circle and B = Confirm, whereas X and A = Cancel.
    In the west it's the other way around.

    Preset E, from the config application, shows the western style. But when you're in-game you will receive the Japanese style.
    Given how you cannot customize the presets, as I explained in my previous post, this basically means that if you pick preset E you're stucked with a japanese layout instead of the western one that probably most of us are used to.
    (0)
    And the autumn of life has finally come
    with the promise of winter thaw.

  7. #7
    Player Zhronne's Avatar
    Join Date
    Mar 2011
    Location
    Italy
    Posts
    1,048
    Character
    Sechs
    World
    Asura
    Main Class
    MNK Lv 99
    On a sidenote, JP people are reporting the same issues as us. Still no official reply yet, but I'm confident this will be handled in next minipatch with other bugs.

    http://forum.square-enix.com/ffxi/th...81%AA%E3%81%84
    (0)
    And the autumn of life has finally come
    with the promise of winter thaw.

  8. #8
    Player Cabalabob's Avatar
    Join Date
    Mar 2011
    Posts
    308
    Character
    Cabalabob
    World
    Phoenix
    Main Class
    SMN Lv 99
    Having the same issue, A is cancel and B is confirm which is completely backwards to what I've been using for 11 years, cannot get used to this, please fix.
    (0)

  9. #9
    Player Nelyus's Avatar
    Join Date
    Feb 2013
    Location
    Bastok
    Posts
    84
    Character
    Nelyus
    World
    Odin
    Main Class
    NIN Lv 99

    Game-pad settings conflict.

    A lot like Zhronne says, I tried 2 different controllers, an Xbox wired for PC & a Logitech F310, both reacts exactly the same way for FFXI & both works perfectly fine for FFXIV.
    The problems I get are that no matter the settings I pick in FFXiPadConfig or FINAL FANTASY XI Config , they are different in the game. Also, any change to the inputs does not carry over in the game.
    There clearly is a conflict problem with the config & the game.
    The only setting I got close to work is E but then the "confirm/select" & "cancel" are inverted in the game. & still, there is no way to change any configurations that would carry into the game.
    This problem occurred because I wanted to change my settings after the November 10 2015 update, because my settings from prior this update were just fine for playing after the update... until I tried to change something.
    I played FFXI for 13 years & its a mess to deal with that, but because I am a Final Fantasy Tactics fan where O was accept & X cancel, I can try to deal with it but as soon as I come back to FFXIV I get so messed up again! );
    Please fix this fast SE! Thank you. (=
    (0)
    Nel.

  10. #10
    Player Szaltax's Avatar
    Join Date
    Nov 2015
    Posts
    1
    Character
    Szaltax
    World
    Asura
    Main Class
    THF Lv 99
    Having identical issue, as described above. Bump for hope of attention and hopefully a quick fix
    (0)

Page 1 of 4 1 2 3 ... LastLast