Results 1 to 1 of 1
  1. #1
    Player Manakind's Avatar
    Join Date
    Feb 2013
    Main Class
    BST Lv 60

    Steam FFXI update has messed up my ffxi.

    im absolutley outraged to log in yesterday and get an update from steam, to my surprise everythng worked ok fine lets play ffxi! i hit play and choose my character and i notice my character's beret hat is missing from his head? so i thought nothing of it and logged in. as i eneter the game my character's hat is missing instead of it being the beret symbol or photo what ever you want to call it in the equipment menu and it was showing as a slab of metal? with no item description? also my gil had letters inbetween digits example 34nm234 ? what the duece? so i ignored that and kept thinking its just a minor glitch and started to ingauge mobs but noticing in the chat bar that it was spamming GM: which was blank after the : nonstop then i tried to cast pollen on my blu and it would cast but the cast bar would be ticking up slow still after casting! not only that i would get the most bizarre spams when ingauged with a mob for example i hit a mob with a spell and it would say i gained 5xx exp from a mob without killing it? LOL then it would say Cover! mob resisted that spell. im here to see if anyone else has this problem as i am outraged and disgusted that one update has forced me to download the game once again 6-7 hours (yay) please please please stop letting people release patches without testing. LOL i mean the game is 10 years old and they still have not devised a good team. any views? please i would love to here them as my evening of gaming has been ruined thanks again!
    Last edited by Manakind; 02-17-2013 at 04:13 AM.