Results 1 to 6 of 6
  1. #1
    Player
    Join Date
    Jan 2013
    Posts
    16

    Help! Graphical Artifacts with Radeon HD7850

    I'm posting here because I have spent quite some time looking online for my specific issue, and have found little to no help. I recently upgraded my gaming rig, and I believe there is a driver issue with the HD Radeon 7850 and FFXI after having done some reading. I can't be certain of course, but the card has no trouble with any other games, and has artifacting in specific areas in FFXI consistently, and other places randomly. I see flashes of lines across the screen or blocks will flash in where there should be an object before the object comes in with no problems. Interestingly it happens far more consistently in areas in which browns or greys are prominent, as well areas with long draw distances, such as Gustaberg. I'll run through Passhow Marshlands or Jugner Forrest and have not a single artifact, but the moment I enter Gustaberg or even Bastok it's nearly constant. I don't believe this to be an issue with the hardware, since as I said I have no issues on other games. Are there settings I can change to fix this issue, or am I stuck waiting and hoping that ATI or SE fixes it? It may be pertinent to note that I'm running the game on an HD TV, though I'm not sure if that matters. Thanks for your time! ^^
    (0)

  2. #2
    Player Zigfreid's Avatar
    Join Date
    Mar 2011
    Posts
    31
    If your card has no issues with other games it could likely be corrupted dats for the zones in question or even a bad sector of your hdd.

    I don't have a Radeon card, however I did have enormous issues with the Rollanberry Fields zone. My screen would have terrible lines and streaks running through it if I faced in certain directions. It was so bad that I could not even navigate the zone without being on follow.
    Nothing I tried, file check, replacing the dats themselves, updating drivers ect, worked.

    I know this isn't usually something someone would want to hear, but the only thing that worked for me was a complete uninstall/reinstall of the game. Personally I run my system on a ssd, so I backed up my macros and what not, uninstalled the game, ran a registry cleaner/ssd cleaner and reinstalled.

    This solution worked for me and it was the only thing that did after hours of trying other tips.
    (0)

  3. #3
    Player Thegreatmonkey's Avatar
    Join Date
    Mar 2011
    Posts
    113
    Character
    Thegreatmonkey
    World
    Asura
    Main Class
    BLM Lv 99
    I have this same problem. Did you try the New Graphics Stabilization option that SE added? I turn that on and it somewhat helps. The problem I have now is that the screen will flash lines of code. I only started to get this problem after upgrading my video card to a Radeon HD 7850. If I remember right, I think FFXI dose not like some Radeon cards and SE knows about this and are trying to fix the problem.
    (0)
    Great place to get games and Systems that are not in your region:
    http://www.play-asia.com/SOap-23-83-fscx.html

  4. #4
    Player
    Join Date
    Jan 2013
    Posts
    16
    It would be nice if they did fix it asap. It's starting to give me a headache when I play. I saw a post on the Japanese forum that said ATI came out with a beta version to the catalyst drivers that gives it better support with Directx9 games. They seemed to think that FFXI was directx9, though I had heard it was directx8. Regardless, they seemed quite satisfied with the new drivers so I may try to download that and hope it helps. Not sure what else to do. -_- Fix this SE, please!
    (0)

  5. #5
    Player Thegreatmonkey's Avatar
    Join Date
    Mar 2011
    Posts
    113
    Character
    Thegreatmonkey
    World
    Asura
    Main Class
    BLM Lv 99
    Quote Originally Posted by Lairenor View Post
    I saw a post on the Japanese forum that said ATI came out with a beta version to the catalyst drivers that gives it better support with Directx9 games
    Oh, I'll give that a try myself after I get my power supply fixed. Thanks!
    (0)
    Great place to get games and Systems that are not in your region:
    http://www.play-asia.com/SOap-23-83-fscx.html

  6. #6
    Player
    Join Date
    Jan 2013
    Posts
    16
    I actually seemed to have fixed it. I did two things at once so I can't say which of these two things fixed it but I updated my motherboard's chipset drivers and I updated to the new (BETA)Catalyst Control Center drivers for my video card. I believe it's 13.2. Now to fix the horrible screen tearing! Anyone have any suggestions for that?
    (0)